I did that just now. I actually had to create the plugins directory under the FF4b1 install directory, but after that, Flash works same as it did with FF 3.6.x. Thanks!

I’ll update the post itself to reflect the resolution of this one issue.